Back to overview
Degraded
Employee HR Portal and Employee Email Portal are down
Apr 9, 2026 at 9:52pm UTC
Affected services
Employee HR Portal
Employee Email Portal
Resolved
Apr 9, 2026 at 11:06pm UTC
Employee Email Portal recovered.
Affected services
Updated
Apr 9, 2026 at 10:47pm UTC
Employee HR Portal recovered.
Affected services
Updated
Apr 9, 2026 at 10:17pm UTC
Employee Email Portal is degraded.
Affected services
Created
Apr 9, 2026 at 9:52pm UTC
Employee HR Portal is degraded.
Affected services