Back to overview
Degraded
Content Delivery Network, Employee HR Portal, and 1 other service are down
Apr 12, 2026 at 7:47am UTC
Affected services
Content Delivery Network
Employee HR Portal
Employee Email Portal
Resolved
Apr 12, 2026 at 9:32am UTC
Content Delivery Network recovered.
Affected services
Updated
Apr 12, 2026 at 9:27am UTC
Employee HR Portal recovered.
Affected services
Updated
Apr 12, 2026 at 9:11am UTC
Employee Email Portal recovered.
Affected services
Updated
Apr 12, 2026 at 8:38am UTC
Employee HR Portal is degraded.
Affected services
Updated
Apr 12, 2026 at 7:58am UTC
Content Delivery Network is degraded.
Affected services
Created
Apr 12, 2026 at 7:47am UTC
Employee Email Portal is degraded.
Affected services