Taunton Group Website, Careers Website, and 3 other services are down
Updated
May 8, 2026 at 1:46pm UTC
We have identified issues within our infrastructure and posted updates across certain domains to allow access and return to normalised state.
There is active maintenance on some web services which will be marked as in maintenance state.
Affected services
Updated
May 8, 2026 at 1:41pm UTC
Content Delivery Network recovered.
Affected services
Updated
Apr 28, 2026 at 11:51pm UTC
Employee Email Portal is degraded.
Affected services
Updated
Apr 28, 2026 at 11:43pm UTC
Taunton Group Website is degraded.
Affected services
Updated
Apr 28, 2026 at 10:32pm UTC
Careers Website is degraded.
Affected services
Updated
Apr 23, 2026 at 9:52pm UTC
Content Delivery Network is degraded.
Affected services
Updated
Apr 23, 2026 at 5:56pm UTC
Employee Email Portal recovered.
Affected services
Updated
Apr 23, 2026 at 5:22pm UTC
Employee HR Portal recovered.
Affected services
Updated
Apr 23, 2026 at 5:07pm UTC
Content Delivery Network recovered.
Affected services
Updated
Apr 23, 2026 at 4:33pm UTC
Content Delivery Network is degraded.
Affected services
Updated
Apr 23, 2026 at 1:18pm UTC
Employee Email Portal is degraded.
Affected services
Updated
Apr 23, 2026 at 12:38pm UTC
Employee HR Portal is degraded.
Affected services
Updated
Apr 23, 2026 at 8:17am UTC
Content Delivery Network recovered.
Affected services
Created
Apr 23, 2026 at 6:23am UTC
Content Delivery Network is degraded.
Affected services