Back to overview
Maintenance

Webservice Maintenance

May 1, 2026 at 11:48am UTC  –  May 8, 2026 at 1:28pm UTC
Affected services
Taunton Group Website
Careers Website
Taunton School Website
Taunton Arms Website
Taunton Development Website
IT Support Website
Support Website
Employee HR Portal
Employee Email Portal

Resolved
May 8, 2026 at 1:28pm UTC

Maintenance ended

Updated
May 8, 2026 at 1:28pm UTC

We have competed basic maintenance - additional maintenance will be taking place.

Created
May 1, 2026 at 11:48am UTC

Several of our web services are undergoing infrastructure maintenance in which these web services will not be available.