Back to overview
Resolved

Indeero Website Not Available

Jun 15, 2026 at 3:54pm UTC
Affected services
Indeero Website

Resolved
Jun 15, 2026 at 4:43pm UTC

We have identified the issue of the outage and can confirm the website is back up and running with no data being lost.

Created
Jun 15, 2026 at 3:54pm UTC

We have had an issue with our domain provider and the website cannot be currently accessed.

Please allow us some time to get this issue resolved and the website back operational.